• tw2 infinite loop?

    From Nightfox@VERT/DIGDIST to All on Friday, September 25, 2015 07:41:26
    This morning I noticed that sbbsctrl was using about 85-95% of the CPU, and I saw that a user was logged in running tw2 (in xtrn/tw2). I opened the "spy on node" window to see what was happening that might be causing such high CPU usage, but it looked like nothing was happening on that node. I also noticed the user had been logged in for about 5 hours, so I suspect there might have been an infinite loop running in tw2 somewhere. I closed sbbsctrl and re-opened it, and now all is fine. I've updated my tw2 files to make sure they're all up to date, but I'm wondering if that is a known issue?

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Digital Man@VERT to Nightfox on Friday, September 25, 2015 13:23:59
    Re: tw2 infinite loop?
    By: Nightfox to All on Fri Sep 25 2015 07:41 am

    This morning I noticed that sbbsctrl was using about 85-95% of the CPU, and I saw that a user was logged in running tw2 (in xtrn/tw2). I opened the "spy on node" window to see what was happening that might be causing such high CPU usage, but it looked like nothing was happening on that node. I also noticed the user had been logged in for about 5 hours, so I suspect there might have been an infinite loop running in tw2 somewhere. I closed sbbsctrl and re-opened it, and now all is fine. I've updated my tw2 files to make sure they're all up to date, but I'm wondering if that is a known issue?

    It's not known to me. :-) I'm sure tw2 could use more testing to handle corner-cases, like the user disconnecting unexpectedly. :-)

    digital man

    Synchronet "Real Fact" #1:
    Synchronet version 2 for DOS and OS/2 was released to the public domain in 1997.
    Norco, CA WX: 92.2F, 36.0% humidity, 2 mph ESE wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Deuce@VERT/SYNCNIX to Nightfox on Saturday, September 26, 2015 11:56:51
    Re: tw2 infinite loop?
    By: Nightfox to All on Fri Sep 25 2015 07:41 am

    sbbsctrl and re-opened it, and now all is fine. I've updated my tw2 files to make sure they're all up to date, but I'm wondering if that is a known issue?

    I'm not aware of it.

    ---
    http://DuckDuckGo.com/ a better search engine that respects your privacy.
    Mro is an idiot. Please ignore him, we keep hoping he'll go away.
    Synchronet My Brand-New BBS (All the cool SysOps run STOCK!)