• Errors tryign to reply to a poll message

    From Nightfox@VERT/DIGDIST to Digital Man on Wednesday, November 01, 2017 13:01:04
    Hi DM,

    With my JavaScript message reader, I've noticed I'm getting a weird error when I try to reply to a poll message. My reader allows voting, but I wanted to also reply to the poster of a poll message with some comments. My script calls bbs.post_msg() to post the reply, and I pass it the sub-board code, reply mode, and message header. On that line, I get the following error:

    Error: can't convert 2147483648 to an integer

    Just before that line, I tried having my script output the sub-board code, reply mode, and message header properties. The number that it was outputting appears to be the auxattr property of the message header. But when my script outputs that information, it generates a different error when it calls bbs.post_msg():
    Error: line 865 js_ParseMsgHeaderObject js_msgbase.c JS_GetPrivate failed

    So it seems something odd is going on if it gets a different error just by outputting some information before calling that function. The sub-board code looks right, and the reply mode value it's using is 64. I'm not sure what might be wrong. My reader doesn't have a problem replying to normal messages; this is only happening when replying to a poll message.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Digital Man@VERT to Nightfox on Wednesday, November 01, 2017 15:24:05
    Re: Errors tryign to reply to a poll message
    By: Nightfox to Digital Man on Wed Nov 01 2017 01:01 pm

    Hi DM,

    With my JavaScript message reader, I've noticed I'm getting a weird error when I try to reply to a poll message. My reader allows voting, but I wanted to also reply to the poster of a poll message with some comments. My script calls bbs.post_msg() to post the reply, and I pass it the sub-board code, reply mode, and message header. On that line, I get the following error:

    Error: can't convert 2147483648 to an integer

    Just before that line, I tried having my script output the sub-board code, reply mode, and message header properties. The number that it was outputting appears to be the auxattr property of the message header. But when my script outputs that information, it generates a different error when it calls bbs.post_msg():
    Error: line 865 js_ParseMsgHeaderObject js_msgbase.c JS_GetPrivate failed

    So it seems something odd is going on if it gets a different error just by outputting some information before calling that function. The sub-board code looks right, and the reply mode value it's using is 64. I'm not sure what might be wrong. My reader doesn't have a problem replying to normal messages; this is only happening when replying to a poll message.

    Have you tried it with a different poll?

    I suspect the problem is with a poll whose results are "closed" (not visible until the poll has been closed), as that sets bit 31 of the auxattr header field and there's an issue converting that in JS.

    digital man

    Synchronet "Real Fact" #85:
    The ZMODEM file transfer protocol is limited to files of 4 gigabytes or smaller.
    Norco, CA WX: 69.7F, 53.0% humidity, 9 mph NNE wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Nightfox on Wednesday, November 01, 2017 15:40:12
    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Wed Nov 01 2017 03:24 pm

    Re: Errors tryign to reply to a poll message
    By: Nightfox to Digital Man on Wed Nov 01 2017 01:01 pm

    Hi DM,

    With my JavaScript message reader, I've noticed I'm getting a weird error when I try to reply to a poll message. My reader allows voting, but I wanted to also reply to the poster of a poll message with some comments. My script calls bbs.post_msg() to post the reply, and I pass it the sub-board code, reply mode, and message header. On that line, I get the following error:

    Error: can't convert 2147483648 to an integer

    Just before that line, I tried having my script output the sub-board code, reply mode, and message header properties. The number that it was outputting appears to be the auxattr property of the message header. But when my script outputs that information, it generates a different error when it calls bbs.post_msg():
    Error: line 865 js_ParseMsgHeaderObject js_msgbase.c JS_GetPrivate failed

    So it seems something odd is going on if it gets a different error just by outputting some information before calling that function. The sub-board code looks right, and the reply mode value it's using is 64. I'm not sure what might be wrong. My reader doesn't have a problem replying to normal messages; this is only happening when replying to a poll message.

    Have you tried it with a different poll?

    I suspect the problem is with a poll whose results are "closed" (not visible until the poll has been closed), as that sets bit 31 of the auxattr header field and there's an issue converting that in JS.

    I just committed what I hope is a fix. Please try it and let me know. I suspect this problem only occurs with polls whose results-visibility are set to "closed".

    digital man

    Synchronet/BBS Terminology Definition #44:
    SEXPOTS = Synchronet External Plain Old Telephone System (POTS) service
    Norco, CA WX: 69.7F, 53.0% humidity, 6 mph NE wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Nightfox@VERT/DIGDIST to Digital Man on Wednesday, November 01, 2017 16:39:07
    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Wed Nov 01 2017 03:24 pm

    Have you tried it with a different poll?

    I tried it just now with a different poll, and it was able to reply without a problem.

    I suspect the problem is with a poll whose results are "closed" (not visible until the poll has been closed), as that sets bit 31 of the auxattr header field and there's an issue converting that in JS.

    The poll that showed the problem was a fairly recent poll, Mr. Cool's "What is your preferred 1990's OS?" poll in Dove-Net General. I'm not sure the poll has been closed.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Nelgin@VERT/EOTLBBS to Nightfox on Wednesday, November 01, 2017 20:31:02
    On Wed, 1 Nov 2017 16:39:07 -0800, "Nightfox" <nightfox@VERT/DIGDIST>
    wrote:


    The poll that showed the problem was a fairly recent poll, Mr. Cool's "What is >your preferred 1990's OS?" poll in Dove-Net General. I'm not sure the poll has
    been closed.

    I think DM means that the results are "closed" to viewing unless you
    have voted yourself.

    Then again, I don't know what I'm talking about most of the time
    anyway...

    ---
    Synchronet End Of The Line BBS - endofthelinebbs.com
  • From Nightfox@VERT/DIGDIST to Digital Man on Thursday, November 02, 2017 09:51:29
    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Wed Nov 01 2017 03:40 pm

    I just committed what I hope is a fix. Please try it and let me know. I suspect this problem only occurs with polls whose results-visibility are set to "closed".

    That seems to have fixed it.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Digital Man@VERT to Nightfox on Thursday, November 02, 2017 14:03:19
    Re: Errors tryign to reply to a poll message
    By: Nightfox to Digital Man on Thu Nov 02 2017 09:51 am

    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Wed Nov 01 2017 03:40 pm

    I just committed what I hope is a fix. Please try it and let me know. I suspect this problem only occurs with polls whose results-visibility are set to "closed".

    That seems to have fixed it.

    Okay, cool. Thanks for the report. There are likely many other places in the Sync JS object where dealing with integers >= 0x80000000 would cause that error. It is strange you got a different error under different conditions, but the "auxattr" hint was what I needed to track this one done. Luckily, all the other SMB header field values don't use bit 31 (much).

    digital man

    Synchronet/BBS Terminology Definition #51:
    Sysop = System Operator
    Norco, CA WX: 61.7F, 69.0% humidity, 5 mph ENE wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Nightfox@VERT/DIGDIST to Digital Man on Friday, November 03, 2017 15:39:12
    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Thu Nov 02 2017 02:03 pm

    I just committed what I hope is a fix. Please try it and let me
    know. I suspect this problem only occurs with polls whose
    results-visibility are set to "closed".

    That seems to have fixed it.

    Okay, cool. Thanks for the report. There are likely many other places in the Sync JS object where dealing with integers >= 0x80000000 would cause that error. It is strange you got a different error under different conditions, but the "auxattr" hint was what I needed to track this one done. Luckily, all the other SMB header field values don't use bit 31 (much).

    I started noticing a lot of instances where sbbsctrl would crash when I tried replying to a message with my reader. It seemed to happen with any message (including regular messages). It didn't happen all the time, but a fairly high frequency (maybe 3 out of 4 times). I have reverted back to some earlier binaries I was using for now.

    Some time ago I had tried building the Synchronet code in debug mode for instances like this where I see crashes, but I wasn't fully successful in getting it to build. Perhaps at some point I'll try again.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Digital Man@VERT to Nightfox on Saturday, November 04, 2017 03:10:39
    Re: Errors tryign to reply to a poll message
    By: Nightfox to Digital Man on Fri Nov 03 2017 03:39 pm

    I started noticing a lot of instances where sbbsctrl would crash when I tried replying to a message with my reader. It seemed to happen with any message (including regular messages). It didn't happen all the time, but a fairly high frequency (maybe 3 out of 4 times). I have reverted back to some earlier binaries I was using for now.

    Some time ago I had tried building the Synchronet code in debug mode for instances like this where I see crashes, but I wasn't fully successful in getting it to build. Perhaps at some point I'll try again.

    That would be helpful. What version of MSVC were you using? Only MSVC 2013 is really supported right now.

    digital man

    Synchronet/BBS Terminology Definition #40:
    REP = QWK Reply
    Norco, CA WX: 56.4F, 81.0% humidity, 0 mph S wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Nightfox@VERT/DIGDIST to Digital Man on Saturday, November 04, 2017 20:15:12
    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Sat Nov 04 2017 03:10 am

    Some time ago I had tried building the Synchronet code in debug mode
    for instances like this where I see crashes, but I wasn't fully
    successful in getting it to build. Perhaps at some point I'll try
    again.

    That would be helpful. What version of MSVC were you using? Only MSVC 2013 is really supported right now.

    I don't remember, but I could try with 2013.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Nightfox@VERT/DIGDIST to Digital Man on Sunday, November 05, 2017 18:38:37
    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Sat Nov 04 2017 02:10 am

    Some time ago I had tried building the Synchronet code in debug mode
    for instances like this where I see crashes, but I wasn't fully
    successful in getting it to build. Perhaps at some point I'll try
    again.

    That would be helpful. What version of MSVC were you using? Only MSVC 2013 is really supported right now.

    The wiki page says certain GUI components (such as sbbsctrl.exe) are built with Borland C++ Builder 6 and transitioning to Embarcadero Technologies C++ Builder:
    http://wiki.synchro.net/dev:tools
    Is that still accurate? I think I was unsure of the process to build the specific components with the different build tools. But if it can all be built with Visual Studio 2013, then I can give that a try.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Nightfox@VERT/DIGDIST to Digital Man on Sunday, November 05, 2017 18:47:30
    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Sat Nov 04 2017 02:10 am

    Some time ago I had tried building the Synchronet code in debug mode
    for instances like this where I see crashes, but I wasn't fully
    successful in getting it to build. Perhaps at some point I'll try
    again.

    That would be helpful. What version of MSVC were you using? Only MSVC 2013 is really supported right now.

    Tonight I downloaded Visual Studio 2013 Express and tried building the Synchronet source code. I loaded sbbs3.sln, and I noticed Visual Studio said it failed to load some projects - ftpsrvr, jsexec, mailsrvr, sbbs, services, and websrvr: http://www.digitaldistortionbbs.com/sbbsCodeBuilding/ProjectLoadFailures.png
    A separate issue - I imagine jsexec (and possibly other projects) may require some setup work to point it to the SpiderMonkey engine? Also I didn't see a sbbsctrl project in there (though the wiki notes that is built with Borland C++ Builder 6)..

    Also, when I tried building the project, Visual Studio 2013 reported the following build errors: http://www.digitaldistortionbbs.com/sbbsCodeBuilding/buildFailures_vs2013.txt

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Digital Man@VERT to Nightfox on Sunday, November 05, 2017 23:42:10
    Re: Errors tryign to reply to a poll message
    By: Nightfox to Digital Man on Sun Nov 05 2017 06:38 pm

    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Sat Nov 04 2017 02:10 am

    Some time ago I had tried building the Synchronet code in debug mode
    for instances like this where I see crashes, but I wasn't fully
    successful in getting it to build. Perhaps at some point I'll try
    again.

    That would be helpful. What version of MSVC were you using? Only MSVC 2013 is really supported right now.

    The wiki page says certain GUI components (such as sbbsctrl.exe) are built with Borland C++ Builder 6 and transitioning to Embarcadero Technologies C++ Builder:
    http://wiki.synchro.net/dev:tools
    Is that still accurate?

    Yes. But you don't have to build those components (e.g. sbbsctrl.exe) - you could just use the sbbsctrl.exe from the nightly dev build combined with the DLLs you build yourself.

    I think I was unsure of the process to build the
    specific components with the different build tools. But if it can all be built with Visual Studio 2013, then I can give that a try.

    The majority of the guts (the DLLs), the console mode apps (including sbbs.exe, scfg.exe, etc.) and the NT services are built with MSVC2013.

    digital man

    Synchronet/BBS Terminology Definition #2:
    ARS = Access Requirement Strings
    Norco, CA WX: 55.3F, 87.0% humidity, 0 mph S wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Nightfox on Sunday, November 05, 2017 23:46:41
    Re: Errors tryign to reply to a poll message
    By: Nightfox to Digital Man on Sun Nov 05 2017 06:47 pm

    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Sat Nov 04 2017 02:10 am

    Some time ago I had tried building the Synchronet code in debug mode
    for instances like this where I see crashes, but I wasn't fully
    successful in getting it to build. Perhaps at some point I'll try
    again.

    That would be helpful. What version of MSVC were you using? Only MSVC 2013 is really supported right now.

    Tonight I downloaded Visual Studio 2013 Express and tried building the Synchronet source code. I loaded sbbs3.sln, and I noticed Visual Studio said it failed to load some projects - ftpsrvr, jsexec, mailsrvr, sbbs, services, and websrvr: http://www.digitaldistortionbbs.com/sbbsCodeBuilding/ProjectLoadFailures.png A separate issue - I imagine jsexec (and possibly other projects) may require some setup work to point it to the SpiderMonkey engine? Also I didn't see a sbbsctrl project in there (though the wiki notes that is built with Borland C++ Builder 6)..

    Also, when I tried building the project, Visual Studio 2013 reported the following build errors: http://www.digitaldistortionbbs.com/sbbsCodeBuilding /buildFailures_vs2013.txt

    Did you download/extract the 3rdp directory from sbbs_src.zip?
    Viewing .ZIP: s:/xfer/sbbs/sbbs_src.zip

    Length Method Size Ratio Date Time CRC-32 Attr Name
    ------ ------ ----- ----- ---- ---- -------- ---- ----
    843 DeflatX 395 53.2% 10/21/2011 4:29a a04c2560 --w---- 3rdp/win32.release/mozjs/mozjs.props

    The "3rdp" directory should be extracted as a sibling directory of the "src" directory.

    digital man

    This Is Spinal Tap quote #26:
    David St. Hubbins: They were still booing him when we came on stage.
    Norco, CA WX: 55.3F, 87.0% humidity, 0 mph S wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Nightfox@VERT/DIGDIST to Digital Man on Monday, November 06, 2017 10:28:09
    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Sun Nov 05 2017 11:46 pm

    Tonight I downloaded Visual Studio 2013 Express and tried building the
    Synchronet source code. I loaded sbbs3.sln, and I noticed Visual
    Studio said it failed to load some projects - ftpsrvr, jsexec,
    mailsrvr, sbbs, services, and websrvr:
    http://www.digitaldistortionbbs.com/sbbsCodeBuilding/ProjectLoadFailur
    es.png A separate issue - I imagine jsexec (and possibly other
    projects) may require some setup work to point it to the SpiderMonkey
    engine? Also I didn't see a sbbsctrl project in there (though the
    wiki notes that is built with Borland C++ Builder 6)..

    Also, when I tried building the project, Visual Studio 2013 reported
    the following build errors:
    http://www.digitaldistortionbbs.com/sbbsCodeBuilding
    /buildFailures_vs2013.txt

    Did you download/extract the 3rdp directory from sbbs_src.zip?
    Viewing .ZIP: s:/xfer/sbbs/sbbs_src.zip

    Length Method Size Ratio Date Time CRC-32 Attr Name
    ------ ------ ----- ----- ---- ---- -------- ---- ----
    843 DeflatX 395 53.2% 10/21/2011 4:29a a04c2560 --w---- 3rdp/win32.release/mozjs/mozjs.props

    The "3rdp" directory should be extracted as a sibling directory of the "src" directory.

    Ah, I hadn't done that. I gave that a try and was able to build the components with VS2013.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Digital Man@VERT to Nightfox on Monday, November 06, 2017 12:09:59
    Re: Errors tryign to reply to a poll message
    By: Nightfox to Digital Man on Mon Nov 06 2017 10:28 am

    The "3rdp" directory should be extracted as a sibling directory of the "src" directory.

    Ah, I hadn't done that. I gave that a try and was able to build the components with VS2013.

    Okay, good to hear.

    digital man

    Synchronet/BBS Terminology Definition #37:
    NUL = ASCII 0
    Norco, CA WX: 68.6F, 60.0% humidity, 1 mph ENE wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Nightfox@VERT/DIGDIST to Digital Man on Wednesday, November 08, 2017 20:02:39
    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Mon Nov 06 2017 12:09 pm

    Ah, I hadn't done that. I gave that a try and was able to build the
    components with VS2013.

    Okay, good to hear.

    After building the debug sbbs3 binaries, I copied them to a test machine, and when I tried running sbbsctrl.exe, I got the error "Incorrect SBBS.DLL version (0)". I tried copying sbbs.dll to C:\Windows\System32 but that didn't help. The test machine I was using has Windows 10 32-bit. Perhaps I should try with an earlier version of Windows?

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Digital Man@VERT to Nightfox on Wednesday, November 08, 2017 22:16:35
    Re: Errors tryign to reply to a poll message
    By: Nightfox to Digital Man on Wed Nov 08 2017 08:02 pm

    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Mon Nov 06 2017 12:09 pm

    Ah, I hadn't done that. I gave that a try and was able to build the
    components with VS2013.

    Okay, good to hear.

    After building the debug sbbs3 binaries, I copied them to a test machine, and when I tried running sbbsctrl.exe, I got the error "Incorrect SBBS.DLL version (0)". I tried copying sbbs.dll to C:\Windows\System32 but that didn't help. The test machine I was using has Windows 10 32-bit. Perhaps I should try with an earlier version of Windows?

    No, that version of Windows should be fine. You don't need to copy any Synchronet DLL other than sbbsexec.dll to the Windows/System32 directory. You should delete that one just to avoid future problems.

    Anyway... as for the problem at hand: please try a a "release" build of the DLLs and see if you get the same error. If you do not get the error with the release DLLs (built by yourself), then I can probably get a copy of sbbsctrl.exe to you that will work with the debug DLLs (which is what you realliy want to run with).

    But... there are alternatives to sbbsctrl.exe, like sbbs.exe and sbbsNTsvcs.exe. Have you tried those (built by yourself)?

    digital man

    This Is Spinal Tap quote #21:
    So when you're playing you feel like a preserved moose on stage?
    Norco, CA WX: 59.5F, 87.0% humidity, 4 mph SE wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Nightfox@VERT/DIGDIST to Digital Man on Sunday, November 12, 2017 19:12:06
    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Wed Nov 08 2017 10:16 pm

    After building the debug sbbs3 binaries, I copied them to a test
    machine, and when I tried running sbbsctrl.exe, I got the error
    "Incorrect SBBS.DLL version (0)". I tried copying sbbs.dll to

    Anyway... as for the problem at hand: please try a a "release" build of the DLLs and see if you get the same error. If you do not get the error with the release DLLs (built by yourself), then I can probably get a copy of sbbsctrl.exe to you that will work with the debug DLLs (which is what you realliy want to run with).

    But... there are alternatives to sbbsctrl.exe, like sbbs.exe and sbbsNTsvcs.exe. Have you tried those (built by yourself)?

    I built the release binaries but still got the same error, "Incorrect SBBS.DLL version (0)".

    I was able to run sbbs.exe (rather than sbbsctrl.exe). I tried replying to several messages and it wasn't crashing.. This was on my test setup on Windows 10, and I'm wondering if that might make a difference. I'm still using Windows XP on my actual BBS machine - I've been thinking of upgrading it, and was going to use Windows 10, but the Windows 10 VM I created for it just seems a bit slow (though it seems to work).

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Digital Man@VERT to Nightfox on Sunday, November 12, 2017 20:23:17
    Re: Errors tryign to reply to a poll message
    By: Nightfox to Digital Man on Sun Nov 12 2017 07:12 pm

    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Wed Nov 08 2017 10:16 pm

    After building the debug sbbs3 binaries, I copied them to a test
    machine, and when I tried running sbbsctrl.exe, I got the error
    "Incorrect SBBS.DLL version (0)". I tried copying sbbs.dll to

    Anyway... as for the problem at hand: please try a a "release" build of the DLLs and see if you get the same error. If you do not get the error with the release DLLs (built by yourself), then I can probably get a copy of sbbsctrl.exe to you that will work with the debug DLLs (which is what you realliy want to run with).

    But... there are alternatives to sbbsctrl.exe, like sbbs.exe and sbbsNTsvcs.exe. Have you tried those (built by yourself)?

    I built the release binaries but still got the same error, "Incorrect SBBS.DLL version (0)".

    I was able to run sbbs.exe (rather than sbbsctrl.exe). I tried replying to several messages and it wasn't crashing.. This was on my test setup on Windows 10, and I'm wondering if that might make a difference. I'm still using Windows XP on my actual BBS machine - I've been thinking of upgrading it, and was going to use Windows 10, but the Windows 10 VM I created for it just seems a bit slow (though it seems to work).

    I doubt Windows 10 vs XP is the difference maker. Do both setups share all the same configuration files?

    digital man

    Synchronet/BBS Terminology Definition #52:
    TCP = Transmission Control Protocol
    Norco, CA WX: 61.2F, 78.0% humidity, 0 mph S wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Nightfox@VERT/DIGDIST to Digital Man on Monday, November 13, 2017 09:54:50
    Re: Errors tryign to reply to a poll message
    By: Digital Man to Nightfox on Sun Nov 12 2017 08:23 pm

    I built the release binaries but still got the same error, "Incorrect
    SBBS.DLL version (0)".

    I was able to run sbbs.exe (rather than sbbsctrl.exe). I tried
    replying to several messages and it wasn't crashing.. This was on my
    test setup on Windows 10, and I'm wondering if that might make a
    difference. I'm still using Windows XP on my actual BBS machine -
    I've been thinking of upgrading it, and was going to use Windows 10,
    but the Windows 10 VM I created for it just seems a bit slow (though
    it seems to work).

    I doubt Windows 10 vs XP is the difference maker. Do both setups share all the same configuration files?

    I had copied my setup from the XP machine to the Windows 10 machine, so both have the same copies of the configuration files.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Nightfox@VERT/DIGDIST to Digital Man on Monday, November 13, 2017 17:03:47
    Re: Errors tryign to reply to a poll message
    By: Nightfox to Digital Man on Mon Nov 13 2017 09:54 am

    I updated my Synchronet binaries to one of the recent builds again (November 11), and today I've replied to a few messages using my reader without any crashes (this is with my BBS machine running Windows XP). So perhaps the crashes were more random than I had thought.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com